Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Kafka does not start after Kerborising the clustrer

Solved Go to solution

Kafka does not start after Kerborising the clustrer

Contributor

All my HDP components succeded to start after kerborising my cluster, except Kakfa...

This is what I can see in /var/log/kafka/server.log:

[2016-01-06 23:04:54,931] FATAL Fatal error during KafkaServer startup. Prepare to shutdown (kafka.server.KafkaServer) java.lang.IllegalArgumentException: You must pass java.security.auth.login.config in secure mode. at org.apache.kafka.common.security.kerberos.Login.login(Login.java:297)

Ambari logs do not show any error message related to the Kafka fail while restarting the service.

I am running HDP 2.3 and Ambari 2.1

Any clue ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Kafka does not start after Kerborising the clustrer

export KAFKA_KERBEROS_PARAMS in /usr/hdp/current/kafka-broker/config/kafka-env.sh you can do this using ambari as well look for kafka-env config template under kafka service.

KAFKA_KERBEROS_PARAMS="-Djava.security.auth.login.config=/usr/hdp/current/kafka-broker/config/kafka_jaas.conf"

6 REPLIES 6

Re: Kafka does not start after Kerborising the clustrer

export KAFKA_KERBEROS_PARAMS in /usr/hdp/current/kafka-broker/config/kafka-env.sh you can do this using ambari as well look for kafka-env config template under kafka service.

KAFKA_KERBEROS_PARAMS="-Djava.security.auth.login.config=/usr/hdp/current/kafka-broker/config/kafka_jaas.conf"

Re: Kafka does not start after Kerborising the clustrer

Contributor

Thank you ! That was fast :)

Re: Kafka does not start after Kerborising the clustrer

@Ali Gouta Schintalapani is Kafka committer ;) http://kafka.apache.org/committers.html

Re: Kafka does not start after Kerborising the clustrer

New Contributor

Kafka is getting started, but through java application I am not able to send message to kafka topic, I have already passed principalName and keytab through application. and set one property CommonClientConfigs.SECURITY_PROTOCOL_CONFIG, "PLAINTEXTSASL",

it gives same error - You must pass java.security.auth.login.config in secure mode

Re: Kafka does not start after Kerborising the clustrer

Expert Contributor

Thanks for this post. kudos!

Re: Kafka does not start after Kerborising the clustrer

Thanks...helped me out right away!

Don't have an account?
Coming from Hortonworks? Activate your account here