Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Metron Quick-dev-platform installation error - kibana : Download Nodesource Yum Repository Setup

Solved Go to solution
Highlighted

Metron Quick-dev-platform installation error - kibana : Download Nodesource Yum Repository Setup

I am running with below configurations:

Managed machine OS - Redhat 7

# ansible --version

ansible 2.0.0.2

# python2.7 -V

Python 2.7.12

(Note: The command python -V gives me 2.7.5 while python2.7 -V gives me 2.7.12)

And I am getting the below error:

TASK [kibana : Download Nodesource Yum Repository Setup] ***********************

fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": "Failed to validate the SSL certificate for rpm.nodesource.com:443. Make sure your managed systems have a valid CA certificate installed. If the website serving the url uses SNI you need python >= 2.7.9 on your managed machine. You can use validate_certs=False if you do not need to confirm the server\\s identity but this is unsafe and not recommended Paths checked for this platform: /etc/ssl/certs, /etc/pki/ca-trust/extracted/pem, /etc/pki/tls/certs, /usr/share/ca-certificates/cacert.org, /etc/ansible"} PLAY RECAP *********************************************************************

node1 : ok=182 changed=40 unreachable=0 failed=1

I tried adding config.vm.box_download_insecure = true to the Vagrantfile and then reloaded vagrant by vagrant reload and provisioning vagrant again. But the error still occurs.

What did I miss? Or is there any way to tell ansible to do this? I saw this validate_certs=False solution on the web, but I am not sure where to add this, if it's a good workaround. Please help. Sorry for this naive question though :)

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Metron Quick-dev-platform installation error - kibana : Download Nodesource Yum Repository Setup

Explorer

This should be solved in https://github.com/apache/incubator-metron/pull/248 which was merged into master a couple days ago (Thanks @David Lyle)

If you can, please try with current master. If you can't then check the PR for the quick change (just a couple lines).

View solution in original post

2 REPLIES 2

Re: Metron Quick-dev-platform installation error - kibana : Download Nodesource Yum Repository Setup

Explorer

This should be solved in https://github.com/apache/incubator-metron/pull/248 which was merged into master a couple days ago (Thanks @David Lyle)

If you can, please try with current master. If you can't then check the PR for the quick change (just a couple lines).

View solution in original post

Highlighted

Re: Metron Quick-dev-platform installation error - kibana : Download Nodesource Yum Repository Setup

It worked! Thanks and cheers!

I am past this hurdle, but somehow the task - [pycapa : Install dependencies] keeps failing because of timeouts while downloading libgcj-4.4.7-17.el6.x86_64.rpm package. The network connectivity seems to be just fine, according to our network admin.

I want to know if I can comment out the content in: "/metron-deployment/roles/pycapa/tasks/pycapa.yml" so that I can skip pycapa setup completely and Metron would still get installed without any hiccups. Or is it okay to ssh node1 and install this package alone and continue with rest of installation/deployment? Whatever works :)

Thanks in advance!

Don't have an account?
Coming from Hortonworks? Activate your account here