Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

MySQL 5.7 Support?

avatar
Contributor

I was reviewing the HWX documentation around supported databases and was trying to find out if MySQL 5.7 is supported. The database matrix shows '5.x' and the minimum requirements documentation for HDP 2.3 calls out 5.6. I am assuming that means 5.6 is the latest, but wanted to know if others are using 5.7 or have heard anything on when that may be added?

1 ACCEPTED SOLUTION

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
8 REPLIES 8

avatar
Master Mentor

avatar
Master Mentor

@Jonas Straub @Matthew Sharp

5.7 works but I don't think that its official supported.

avatar

Thats true, I was talking about compatibility not support. Let me ping our colleagues from support and see what they say 🙂

avatar

I think I have used MySQL 5.7 for a couple of my test clusters (at least for ambari), I cant remember any issues though. @jeff might know more

Make sure 5.7 is supported by your OS, some RedHat versions ship an older MySql version and have problems with the newest ones.

avatar

I can tell you that for our System Testing we certify MySQL 5.6 which is what the documents as pointed out by @Neeraj Sabharwal say.

avatar
Rising Star

I have found issues when you are using the latest MySQL 5.7 with Ranger. To work around, you need to do the following in /etc/my.cnf

show_compatibility_56 = on

explicit_defaults_for_timestamp

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Explorer

I know this is an old post. However, I did send out a support inquiry as to WHEN 5.7 will be supported and got the response that it was being tested for Ambari v2.5. That was very early this year. There are various vulnerabilities identified by Oracle related to not running higher than 5.7.11. In particular, the vulnerabilities cover: MySQL Server 5.6.29 and earlier, 5.7.11 and earlier. There are no workarounds or alternatives for this issue...Not good.

I am referring to Oracle Support Note 2120034.1 for the preferred solution. This issue was identified by our security team in May 2016. So, my question is this. WHEN will 5.7.11+ be supported?