Support Questions
Find answers, ask questions, and share your expertise

Nifi GetTwitter not working - Authorization Required

Solved Go to solution
Highlighted

Re: Nifi GetTwitter not working - Authorization Required

Contributor

I did but I have no more information in debug mode :

2017-04-28 14:05:35,507 ERROR [Timer-Driven Process Thread-8] o.a.nifi.processors.twitter.GetTwitter GetTwitter[id=60003148-812e-14ce-9c95-0df056d3325d] Received error HTTP_ERROR: HTTP/1.1 401 Authorization Required. Will attempt to reconnect

Highlighted

Re: Nifi GetTwitter not working - Authorization Required

Contributor

It happened that I imported a template with the processor GetTwitter and the version of the processor seemed to be old.

I removed it and added a new one from the tool bar.

It works now!

View solution in original post

Highlighted

Re: Nifi GetTwitter not working - Authorization Required

New Contributor

Syncing NTP server is what worked for me(NiFi 1.6) :

on centos 6:

  • service ntpd stop
  • ntpd -gq

where -g – requests an update irrespective of the time offset

-q – requests the daemon to quit after updating the date from the NTP server.

  • service ntpd start