Support Questions

Find answers, ask questions, and share your expertise

Oozie skipping action as coordinators instance getting created after materialized time

New Contributor

off late i am seeing this issue in oozie , where the instance of a coordinator is getting kicked up after the (next materialized time) , for e.g if the coordinator was scheduled to start next action at 10 AM its only starting may 30 mins post that , and because of that it just creates the action and marks it as skipped with message current time is later than the nominal time of the next action


Question : Why is oozie not creating the action when it should ?

I have checked CPU utilization and memory utilization of server thinking server unable to trigger the action but server stats looks good ( CPU under 50 , memory under 20 %)



2018-01-08 13:55:58,572 INFO org.apache.oozie.command.coord.CoordActionInputCheckXCommand: SERVER[xxxxxxx.internal] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[0014607-171123123643404-oozie-oozi-C] ACTION[0014607-171123123643404-oozie-oozi-C@299] LAST_ONLY execution: Preparing to skip action [0014607-171123123643404-oozie-oozi-C@299] because the current time [2018-01-08T13:55Z] is later than the nominal time [2018-01-08T13:55Z] of the next action]

<coordinator-app name="${co_pend_publish}" start="${startTime}" end="${endTime}" timezone="${timezone}" frequency="${pend_pub_coord_frequency}" xmlns="uri:oozie:coordinator:0.2"> <controls> <timeout>${pend_pub_coord_timeout}</timeout> <execution>LAST_ONLY</execution> <throttle>1</throttle> </controls> <datasets> <dataset initial-instance="${startTime}" name="publish_flag" frequency="5" timezone="${timezone}"> <uri-template>${dataRoot}/publish</uri-template> <done-flag>${publish_manifest}</done-flag> </dataset> </datasets> <input-events> <data-in name="publish_flag_event" dataset="publish_flag"> <start-instance>${coord:current(0)}</start-instance> <end-instance>${coord:current(0)}</end-instance> </data-in> </input-events> <action> <workflow> <app-path>${automationAppRoot}/workflows/${wf_dir_name}</app-path> <configuration> <property> <name>nameNode</name> <value>${nameNode}</value> </property> <property> <name>jobTracker</name> <value>${jobTracker}</value> </property> </configuration> </workflow> </action> </coordinator-app>

2 REPLIES 2

New Contributor

In your coordinator.xml set execution property to FIFO instead of LAST_ONLY.

<execution>FIFO</execution>

This might work. 

New Contributor

Nice post