Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Problem installing a parcel on a brand new cluster

SOLVED Go to solution
Highlighted

Problem installing a parcel on a brand new cluster

New Contributor

We have installed manager successfully however when we go to deploy a parcel (for Kafka) we get an install failure message (sorry I don't have access to the exact message text).  We believe it has something to do with account permissions, something about password-less root logins required on the nodes.  We can't find clear guidance in the installation documents concerning what types of accounts and priveleges are required on the manager and the nodes.  If anyone can clarify this we'd appreciate it!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problem installing a parcel on a brand new cluster

Master Guru
Parcel deployment on an existing cluster does not rely on SSH logins. Only installation of new agent hosts do, during which a form is presented to pass these credentials.

The way we deploy parcels in CM is by having the CM server download it locally to its configured parcel repo disk, and then this file is sent to the agents via the HTTP service that CM runs (agents are instructed to download it from the CM server, which now acts as the repo). The entire procedure relies simply on connected agents, and involves no extra login requirements.

It would be helpful if you can share a snippet of the message seen or explain your workflow more (especially if the failure you observe is consistent).
3 REPLIES 3

Re: Problem installing a parcel on a brand new cluster

Master Guru
Parcel deployment on an existing cluster does not rely on SSH logins. Only installation of new agent hosts do, during which a form is presented to pass these credentials.

The way we deploy parcels in CM is by having the CM server download it locally to its configured parcel repo disk, and then this file is sent to the agents via the HTTP service that CM runs (agents are instructed to download it from the CM server, which now acts as the repo). The entire procedure relies simply on connected agents, and involves no extra login requirements.

It would be helpful if you can share a snippet of the message seen or explain your workflow more (especially if the failure you observe is consistent).

Re: Problem installing a parcel on a brand new cluster

Explorer

We are also seeing same issue but we have 3 agents and a CM. I could see all the agents in the CM as connected but its not working when trying to install via Parcels. I have created local parcel directory and files in that directory but its still grayed out in the CM to proceed further. Can you suggest if something is missing or in the parcel. Thanks in advance!

Re: Problem installing a parcel on a brand new cluster

New Contributor
Thanks, we resolved this issue.