Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ranger blocks ambari-qa user from Hbase smoke test

Solved Go to solution
Highlighted

Ranger blocks ambari-qa user from Hbase smoke test

Contributor

The hbase smoke test is ran from Service Check in ambari and obviously Hbase Ranger policy doesn't know anything about ambari-qa user? Can we change that? or add ambari-qa user to the policy?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Ranger blocks ambari-qa user from Hbase smoke test

Policy created by ranger hbase plugin (when it was enabled) should have granted permission for ambari-qa user. Please check if this policy got deleted. And yes, you can add the user to policy.

View solution in original post

4 REPLIES 4
Highlighted

Re: Ranger blocks ambari-qa user from Hbase smoke test

Policy created by ranger hbase plugin (when it was enabled) should have granted permission for ambari-qa user. Please check if this policy got deleted. And yes, you can add the user to policy.

View solution in original post

Re: Ranger blocks ambari-qa user from Hbase smoke test

Contributor

The policy is there but I don't see ambari-qa in the list of external users.

Highlighted

Re: Ranger blocks ambari-qa user from Hbase smoke test

@Hassan Were you able to test this as suggested by @vperiasamy?

Highlighted

Re: Ranger blocks ambari-qa user from Hbase smoke test

Contributor

@Neeraj Sabharwal Yes, I had to create a local ambari-qa user to have the Hbase check status to work.

Don't have an account?
Coming from Hortonworks? Activate your account here