Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

Solved Go to solution
Highlighted

'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

Contributor

In cluster mode of NiFi 1.0.0. I try to distribute the flowfiles from primary node to cluster nodes by using Remote Process Group.

The property 'Transport Protocol' of Remote Process Group is 'RAW'. I get the error message:

'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

How to resolve it?

Thanks for your help.

David

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: 'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

Master Guru

@David DN

Before Site-to-Site (S2S) can be used the following properties must be set in the nifi.properties file on all the Nodes in your NiFi cluster:

# Site to Site properties
nifi.remote.input.host=<FQDN of Host>              <-- Set to resolveable FQDN by all Nodes
nifi.remote.input.secure=false                     <-- Set to True on if NiFi is running HTTPS
nifi.remote.input.socket.port=<Port used for S2S)  <-- Needs to be set to support Raw/enable S2S
nifi.remote.input.http.enabled=true                <-- Set if you want to support HTTP transport
nifi.remote.input.http.transaction.ttl=30 sec

A restart of your NiFi instances will be necessary for this change to take affect.

Matt

View solution in original post

3 REPLIES 3
Highlighted

Re: 'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

Master Guru

@David DN

Before Site-to-Site (S2S) can be used the following properties must be set in the nifi.properties file on all the Nodes in your NiFi cluster:

# Site to Site properties
nifi.remote.input.host=<FQDN of Host>              <-- Set to resolveable FQDN by all Nodes
nifi.remote.input.secure=false                     <-- Set to True on if NiFi is running HTTPS
nifi.remote.input.socket.port=<Port used for S2S)  <-- Needs to be set to support Raw/enable S2S
nifi.remote.input.http.enabled=true                <-- Set if you want to support HTTP transport
nifi.remote.input.http.transaction.ttl=30 sec

A restart of your NiFi instances will be necessary for this change to take affect.

Matt

View solution in original post

Highlighted

Re: 'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

Expert Contributor

Hi @Matt Clarke. I have been using nifi fine in a virtual machine. Recently i have it installed on my windows 10 host but i keep getting the same error as above even though i have configured the nifi.properties file as follows. I am just using localhost at the minute as i have minifi also installed for testing.

# Site to Site properties
nifi.remote.input.host=localhost
nifi.remote.input.secure=false
nifi.remote.input.socket.port=10000
nifi.remote.input.http.enabled=true
nifi.remote.input.http.transaction.ttl=30 sec

# web properties #
nifi.web.war.directory=./lib
nifi.web.http.host=
nifi.web.http.port=9191
nifi.web.https.host=
nifi.web.https.port=
nifi.web.jetty.working.directory=./work/jetty
nifi.web.jetty.threads=200

Is there any other configurations to be changed? Thank you

Re: 'Remote instance of NiFi is not configured to allow RAW Socket site-to-site communications'

Master Guru

@Roger Young

I assume the Remote Process Group (RPG) is on MiNiFi.

Try checking the following things:

1. NiFi will not fail startup if it cannot bind to the configured nifi.renote.input.socket.port. Make sure there are no other applications or NiFi instances running on this box that way have already bound to this port. Try using a different port and restarting

2. Since you are just testing, try leaving nifi.remote.input.host blank or setting it to 127.0.0.1 instead on your Windows 10 install.

Thanks,

Matt

Don't have an account?
Coming from Hortonworks? Activate your account here