Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Role_extractor for statestore

avatar
Not applicable

Hi,

 

For the last day or so, every hour, our cloudera-scm-agent.log on the host for the impala statestore has been presenting the error message:

 

33923 MonitorDaemon-Reporter throttling_logger ERROR    (59 skipped) Role_extractor for STATESTORE is not initialized correctly.

 

Has anyone seen this before; is it something to be concerned about?

1 ACCEPTED SOLUTION

avatar
Master Guru

@Former Member,

 

Thanks for the question.  The message can be ignored as the error is incorrectly thrown due to a bit of mistaken code logic around the role extractor.

 

It is a false positive.

View solution in original post

2 REPLIES 2

avatar
Master Guru

@Former Member,

 

Thanks for the question.  The message can be ignored as the error is incorrectly thrown due to a bit of mistaken code logic around the role extractor.

 

It is a false positive.

avatar
Master Guru

@Former Member,

 

I just worked with Cloudera engineering and we have fixed up the code logic that led to the false ERROR.  I tested and it looks good.

We'll add the fix into future releases.

 

Cheers,

 

Ben