Support Questions
Find answers, ask questions, and share your expertise

Sandbox - web ui problem

Expert Contributor

Hi,

when i setup NAT or bridged connection inside the oracle Virtualbox the local :8080 /:8000 /:8888 web ui doesnt work!

Any idea? Im really tired of that sanbox, how can one works with it if its fully of bugs.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Sandbox - web ui problem

Expert Contributor

Ok, problem was with postgre, this partially helped

pg_resetxlog -f /var/lib/pgsql/data

View solution in original post

12 REPLIES 12

Re: Sandbox - web ui problem

Expert Contributor

@John SmithCheck that Port forwarding is setup.

I have NAT setup on my sandbox(which is in fact default setting) and all UI works fine.

Here is how it looks in my sandbox

1453-capture.png

Re: Sandbox - web ui problem

@John Smith

Generally, you don't have to do anything except importing the sandbox image.

1) Networks

1454-screen-shot-2016-01-19-at-55009-am.png

2) This is setup during the install.

1455-screen-shot-2016-01-19-at-55023-am.png

Re: Sandbox - web ui problem

Re: Sandbox - web ui problem

Rising Star

Hi @John Smith,

The network for the Sandbox should be setup out of the box and no need to reconfigure. May I ask why you are reconfiguring the network for the virtual machine?

Regards,

Robert

Re: Sandbox - web ui problem

Expert Contributor

Apparently its not ... when i do telnet localhost 8080 the port is not open ... but 8000 works. .. i dont know why.

Re: Sandbox - web ui problem

Mentor

@John Smith

Check status of ambari and Start ambari by running 'ambari-server status' if not running 'ambari-server start

Re: Sandbox - web ui problem

Re: Sandbox - web ui problem

Re: Sandbox - web ui problem

Expert Contributor
[root@sandbox ~]# ambari-server status Using python /usr/bin/python2.6 
Ambari-server status Ambari Server not running. Stale PID File at: 
/var/run/ambari-server/ambari-server.pid [root@sandbox ~]# ambari-server
 start Using python /usr/bin/python2.6 Starting ambari-server Ambari 
Server running with administrator privileges. Running initdb: This may 
take upto a minute. About to start PostgreSQL ERROR: Exiting with exit 
code 3. REASON: Unable to start PostgreSQL server. Status stopped. . 
Exiting