Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Sqoop job name

Solved Go to solution
Highlighted

Sqoop job name

Hi,

I am looking for a way to specify the name of my Sqoop job (export to Teradata). Here is the command I execute:

/usr/bin/sqoop export \
        -Dteradata.db.output.method=internal.fastload \
        --connect <connection> \
        --connection-manager org.apache.sqoop.teradata.TeradataConnManager \
        --username myuser \
        --password mypassword \
        --table <table> \
        --export-dir <sourceDir> \
        --num-mappers <mappers> \
        --verbose \
        --input-null-non-string ''

I tried the following options in the command:

        -Dmapreduce.job.id="myJob"
        -Dmapreduce.job.name="myJob" \

But it seems to be ignored and my job is always named "TeradataSqoopExportJob".

Is there a way to rename the job?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Sqoop job name

Guru

@Pierre Villard I got it working with -D mapred.job.name=mySqoopTest

3 REPLIES 3

Re: Sqoop job name

Super Guru

@Pierre Villard

can you please try the --create myjobname

sqoop job --create myjob -- import --connect jdbc:mysql://example.com/db \
    --table mytable

Re: Sqoop job name

I'd prefer a solution without using the Sqoop metastore, but I'll try that anyway and let you know. I believe that in this case, that this is overridden by the connector code and not sure if we can do much.

Re: Sqoop job name

Guru

@Pierre Villard I got it working with -D mapred.job.name=mySqoopTest

Don't have an account?
Coming from Hortonworks? Activate your account here