Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Sqoop job name

avatar

Hi,

I am looking for a way to specify the name of my Sqoop job (export to Teradata). Here is the command I execute:

/usr/bin/sqoop export \
        -Dteradata.db.output.method=internal.fastload \
        --connect <connection> \
        --connection-manager org.apache.sqoop.teradata.TeradataConnManager \
        --username myuser \
        --password mypassword \
        --table <table> \
        --export-dir <sourceDir> \
        --num-mappers <mappers> \
        --verbose \
        --input-null-non-string ''

I tried the following options in the command:

        -Dmapreduce.job.id="myJob"
        -Dmapreduce.job.name="myJob" \

But it seems to be ignored and my job is always named "TeradataSqoopExportJob".

Is there a way to rename the job?

Thanks!

1 ACCEPTED SOLUTION

avatar
Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
3 REPLIES 3

avatar
Master Guru

@Pierre Villard

can you please try the --create myjobname

sqoop job --create myjob -- import --connect jdbc:mysql://example.com/db \
    --table mytable

avatar

I'd prefer a solution without using the Sqoop metastore, but I'll try that anyway and let you know. I believe that in this case, that this is overridden by the connector code and not sure if we can do much.

avatar
Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login