Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Unable to Start HiveServer2 in Ambari

avatar
Visitor

Hello. I'm a data analyst who was unfortunately tasked to fix an issue with hive. I tried

  • Restarting all HDFS Components - success
  • Restarting all Hive Components - failed.
    • Restart HiveServer2 has failed 
      • 1 / 4 nodes have failed. The node that failed is not the master node
    • Other components was started succesfully.
1 ACCEPTED SOLUTION

avatar
Expert Contributor

hello @Benj1029 

 

You need to go to the below path on the host which is hosting HIveserver2 process.

 

cd /var/log/hive/

 

vi hiveserver2.log file and just before the shutdown try looking at the stack trace, the would help you with some pointers.

View solution in original post

2 REPLIES 2

avatar
Expert Contributor

hello @Benj1029 

 

You need to go to the below path on the host which is hosting HIveserver2 process.

 

cd /var/log/hive/

 

vi hiveserver2.log file and just before the shutdown try looking at the stack trace, the would help you with some pointers.

avatar
Visitor

Thanks. Turned out it's related to incorrect IP.