Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Unable to move source hdfs to local

avatar
Contributor

Hello,

 

I am trying to execute 1 .hql script from Edge node. [hdp-slave4.mydomain.com]

hdp-slave4 machine is not running any server roles i.e. zookeeper or hive. Only having zookeeper & hive clients.

HDP version: 3.1.4

Command =  hive -f ./dumping_test_script.hql

I am getting following error =

INFO : Moving data to local directory /home/user1/user1_Run_Jar/AB_HIVE_1805 2021/neo4j-graph-preparation/data-files/user_stats from hdfs://hdp-master.mydomain .com:8020/tmp/hive/hive/df588c46-4e05-4a5c-8fde-5b7aaf9329a6/hive_2021-06- 01_13-55-09_157_7991483949013764396-29555/-mr-10000
ERROR : FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.ex ec.MoveTask. Unable to move source hdfs://hdp-master.mydomain.com:8020/tmp/hive/hive/df588c46-4e05-4a5c-8fde-5b7aaf9329a6/hive_2021-06-01_13-55-09_157_79914 83949013764396-29555/-mr-10000 to destination /home/user1/user1_Run_Jar/AB_HIVE_18052021/neo4j-graph-preparation/data-files/user_stats
DEBUG : Shutting down query INSERT OVERWRITE LOCAL DIRECTORY '/home/user1/user1 _Run_Jar/AB_HIVE_18052021/neo4j-graph-preparation/data-files/user_stats'
ROW FORMAT DELIMITED FIELDS TERMINATED BY '\u001'
SELECT type, identifier, product, instance, user_id, app_id
FROM user_stats

 

Any hints how to fix this issue? Thanks.

 

Regards,

Amey.

 

 

1 REPLY 1

avatar
Contributor

I ensured that the path exists on local system i.e. home/user1/user1_Run_Jar/AB_HIVE_1805 2021/neo4j-graph-preparation/data-files/user_stats  & has 777 permissions recursively.

 

But still same error.