Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Solved Go to solution
Highlighted

Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Explorer

actually I am testing cm5.7.0(el6) + cdh5.7.0, and after the installation of cm and the setup of cdh parcels, the webpage told me that "cdh5.7.0 are too new of cm5.7.0". Any one can explain this?

cloudera-manager-el6-cm5.7.0_x86_64.tar.gz 2016-04-02 00:18 573M  
CDH-5.7.0-1.cdh5.7.0.p0.45-el6.parcel 2016-03-31 19:56 1.3G  

 

By the way, why the url "http://archive.cloudera.com/cdh5/parcels/latest/" targeting to 

5.3.10/ 2016-04-21 07:31 -  
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Super Collaborator

Ah ok :) - Per your comment, you are in CM 5.7.0 and the page is listing version CDH 5.7.0.

As the message indicate "Version of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown" what the message effectively saying is that, if there was a version eg: CDH 5.8.0 that page won't show it.

 

Per specification:

Cloudera Manager minor version has to be equal to or greater than the CDH minor version.

For example:

Target CDH Version Minimum Cloudera Manager Version
5.0.55.0.x
5.1.45.1.x
5.4.15.4.x

 

References

http://www.cloudera.com/documentation/enterprise/latest/topics/cm_mc_upgrade_cdh4_to_5.html

 

View solution in original post

9 REPLIES 9
Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Super Collaborator

Can you let me know your Cloudera Manager version, this should be in the CM Web UI in the top-right menu Support> About

 

> By the way, why the url "http://archive.cloudera.com/cdh5/parcels/latest/" targeting to 5.3. 

 

To simplify this transition away from a /latest symlink mechanism, CM 5.4 and higher make use of a Remote Parcel Repository URL configuration variable that lets the Cloudera Manager Server negotiate and determine the Highest-Supported CDH version using this {latest_supported} variable. If you upgrade to Cloudera Manager 5.4.0 or higher and wish to see all supported CDH parcel versions, ensure your parcel settings for Report Parcel Repository URLs contains a property similar to the following (assuming your cluster can contact archive.cloudera.com):

http://archive.cloudera.com/cdh5/parcels/{latest_supported}

 

reference:

https://community.cloudera.com/t5/Cloudera-Manager-Installation/Why-is-CDH-5-4-not-set-as-the-latest...

Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Explorer

2016-05-16 18-06-26屏幕截图.png

It seems that both cm and cdh version are 5.7.0 

Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Explorer
It seems that both cm and cdh version are 5.7.0
Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Super Collaborator

Indeed, you do appear to have version CM 5.7.0.

 

Would you mind posting a screenshot of the page that showing the error, the list of available parcels on your CM from the parcels url

- http://CM-SERVER:7180/api/v12/clusters/REPLACE_WITH_CLUSTER_NAME/parcels

- http://CM-SERVER:7180/api/v12/clusters/REPLACE_WITH_CLUSTER_NAME/parcels/usage

and finally yourREMOTE_PARCEL_REPO_URLS from the following url

- http://CM-SERVER:7180/api/v12/cm/config

Thank you

Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Explorer

I tried to setup a new cm server, but installation can go on, it seems just a warning.2016-05-18 13-56-29屏幕截图.png

Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Super Collaborator

Ah ok :) - Per your comment, you are in CM 5.7.0 and the page is listing version CDH 5.7.0.

As the message indicate "Version of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown" what the message effectively saying is that, if there was a version eg: CDH 5.8.0 that page won't show it.

 

Per specification:

Cloudera Manager minor version has to be equal to or greater than the CDH minor version.

For example:

Target CDH Version Minimum Cloudera Manager Version
5.0.55.0.x
5.1.45.1.x
5.4.15.4.x

 

References

http://www.cloudera.com/documentation/enterprise/latest/topics/cm_mc_upgrade_cdh4_to_5.html

 

View solution in original post

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

Explorer
That's my misunderstanding, taking the comment and explaination (saying newer version not support) as a warning. Sorry.
Thank your goodness.
Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

New Contributor

Hi upo,

 

Have you changed anything in 'More Options'?

 

My 'More Options' setting:

Parcel Directory: /opt/cloudera/parcels

Local Parcel Repository Path: /opt/cloudera/parcel-repo

Remote Parcel Repository URLs: Remain unchanged

 

Basicall I haven't changed anything and in my local disk I put parcels in /opt/cloudera/parcel-repo.

 

[root@n003 parcel-repo]# ls -lt
total 1467124
-rw-r--r-- 1 root root 43243 Apr 21 2016 manifest.json
-rw-r--r-- 1 root root 41 Apr 21 2016 CDH-5.3.10-1.cdh5.3.10.p0.19-el6.parcel.sha1
-rw-r--r-- 1 root root 1502281283 Apr 21 2016 CDH-5.3.10-1.cdh5.3.10.p0.19-el6.parcel

 

How did you make the version of CDH visible?  Please advise.

 

Thanks,

Highlighted

Re: Versions of CDH that are too new for this version of Cloudera Manager (5.7.0) will not be shown.

New Contributor
{
  "message" : "Cluster 'REPLACE_WITH_CLUSTER_NAME' not found."
}

how to solve this? 

Don't have an account?
Coming from Hortonworks? Activate your account here