Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

While running sql commands in Zeppelin notebook

avatar
Explorer

%sql
select * from enrichedEvents order by hoursDriven desc limit 20

 

Table or view not found: enrichedEvents; line 1 pos 14
set zeppelin.spark.sql.stacktrace = true to see full stacktrace
 
Why this error coming in HDP 2.6.0 where no issues with HDP 3.0 sandbox. Any confugration changes in Zeppelin notebo
1 ACCEPTED SOLUTION

avatar
Super Collaborator

Hello @SurajP 

 

Thanks for using Cloudera Community. You mentioned the SQL works in Zeppelin Notebook on HDP v3.0 while doesn't work on HDP v2.6. 

 

The error posted by you points to the fact that the Table "enrichedEvents" isn't found. The same isn't likely caused by any Configuration issues, rather pointing to the absence of the Table. You haven't mentioned the Interpreter used, yet would request you to query the Metadata to confirm if the concerned Object "enrichedEvents" is listed in the Metadata. Accordingly, you can proceed with the SQL. 

 

- Smarak

View solution in original post

3 REPLIES 3

avatar
Super Collaborator

Hello @SurajP 

 

Thanks for using Cloudera Community. You mentioned the SQL works in Zeppelin Notebook on HDP v3.0 while doesn't work on HDP v2.6. 

 

The error posted by you points to the fact that the Table "enrichedEvents" isn't found. The same isn't likely caused by any Configuration issues, rather pointing to the absence of the Table. You haven't mentioned the Interpreter used, yet would request you to query the Metadata to confirm if the concerned Object "enrichedEvents" is listed in the Metadata. Accordingly, you can proceed with the SQL. 

 

- Smarak

avatar
Master Collaborator

@SurajP Can you check is hive-site.xml is copied to /etc/spark/conf/ if not please copy hive-site.xml to spark conf directory

 

Also Can you try running "show databases" command to check is all the databases are listing

 

 

avatar
Explorer

Solved. Thank you