Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-10-2021 07:44 AM
%sql
select * from enrichedEvents order by hoursDriven desc limit 20
Created 01-10-2021 10:07 PM
Hello @SurajP
Thanks for using Cloudera Community. You mentioned the SQL works in Zeppelin Notebook on HDP v3.0 while doesn't work on HDP v2.6.
The error posted by you points to the fact that the Table "enrichedEvents" isn't found. The same isn't likely caused by any Configuration issues, rather pointing to the absence of the Table. You haven't mentioned the Interpreter used, yet would request you to query the Metadata to confirm if the concerned Object "enrichedEvents" is listed in the Metadata. Accordingly, you can proceed with the SQL.
- Smarak
Created 01-10-2021 10:07 PM
Hello @SurajP
Thanks for using Cloudera Community. You mentioned the SQL works in Zeppelin Notebook on HDP v3.0 while doesn't work on HDP v2.6.
The error posted by you points to the fact that the Table "enrichedEvents" isn't found. The same isn't likely caused by any Configuration issues, rather pointing to the absence of the Table. You haven't mentioned the Interpreter used, yet would request you to query the Metadata to confirm if the concerned Object "enrichedEvents" is listed in the Metadata. Accordingly, you can proceed with the SQL.
- Smarak
Created 01-10-2021 10:27 PM
@SurajP Can you check is hive-site.xml is copied to /etc/spark/conf/ if not please copy hive-site.xml to spark conf directory
Also Can you try running "show databases" command to check is all the databases are listing
Created 01-18-2021 08:50 AM
Solved. Thank you