Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-01-2026 10:15 AM
I just finished installing a new cluster but failed to start the zookeeper service. Each instance started but had the "bad health" flag. The zookeeper log on node 3 showed this error repeatedly.
++++
Cannot open channel to 1 at election address node1/61.62.63.1:4181
java.net.ConnectException: Connection refused
++++
On node 3, the connection to node 1 zookeeper port showed no issue.
$ nc -zv node1 4181
Ncat: Version 7.92 ( https://nmap.org/ncat )
Ncat: Connected to 61.62.63.1:4181.
Ncat: 0 bytes sent, 0 bytes received in 0.01 seconds.
On node1, the zookeeper port is open too
$ ss -tulnp | grep 4181
tcp LISTEN 0 50 61.62.63.1:4181 0.0.0.0:*
The private cloud base cluster is 7.1.9 sp1.
Thank you.
Regards,
Created 06-02-2026 10:40 AM
Cloudera Support helped me resolved this issue.
Created 06-01-2026 02:54 PM
@Seaport Hello team @pajoshi @shubham_sharma
Do you have any insights here? Thanks!
Regards,
Diana Torres,Created 06-02-2026 12:38 AM
Hello @Seaport ,
Can you check if the reverse DNS lookup is working fine from each zookeeper host. Also worth checking the zoo.cfg file under the latest /var/run/cloudera-scm-agent/process/ xxxx-zookeeper-server/ directory to check how the servers and ports are configured.
Created 06-02-2026 10:40 AM
Cloudera Support helped me resolved this issue.