Support Questions

Find answers, ask questions, and share your expertise

ambari-server install requires python26

New Contributor

i am trying to install ambari-server, but getting "requires python26" error. my environment is centos 6.6 with python 2.6 installed by default. I am sure the python 26 is available. anything wrong?

1 ACCEPTED SOLUTION

3 REPLIES 3

Mentor

@wei jiang see if you have multiple python versions loaded, do you have any old ambari files? Run "rpm -qa | grep ambari". See if you have any ambari files in /usr/lib/python2.6/site-packages you may need to remove them first. Please paste the whole error in /var/log/ambari-server/

@wei jiang

yum install python26

and retry installing ambari

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.