Support Questions
Find answers, ask questions, and share your expertise

cloudera-manager-installer.bin fails in redhat-7 with openjdk issue

New Contributor

I am trying to install Cloudera in AWS for test purposes and the first obstacle I ran into was when I tried to run the cloudera-manager-installer.bin which I downloaded from https://archive.cloudera.com/p/cm7/7.3.1/cloudera-manager-installer.bin.

 

The problem is that when you run this it fails with "

https://archive.cloudera.com/cm7/7.3.1/redhat7/yum/repodata/repomd.xml: [Errno 14]  Error 404 - The requested URL returned error: 404 Not Found" and this seems like a bug because the file is there but in a diff location ie https://archive.cloudera.com/p/cm7/7.3.1/redhat7/yum/repodata/repomd.xml (please note the "p" in working link . 

 

How do we fix this ? Looks like installer is looking in wrong location ? 

1 REPLY 1

Re: cloudera-manager-installer.bin fails in redhat-7 with openjdk issue

@Sam2020 This is because Cloudera recently changed the download policy and now to download Cloudera Software you need a valid subscription. 

Please see the announcement here: Transition to private repositories for CDH, HDP and HDF

This is because of recent changes with respect to Paywall. Same has been answered in below thread :

https://community.cloudera.com/t5/Support-Questions/http-public-repo-1-hortonworks-com-ambari-centos...

 

One solution would be to download the installed (Trial version from here) 

$ wget https://archive.cloudera.com/cm7/7.1.4/cloudera-manager-installer.bin
$ chmod u+x cloudera-manager-installer.bin
$ sudo ./cloudera-manager-installer.bin

For more details on Trial see: https://www.cloudera.com/downloads/cdp-private-cloud-trial.html


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.