Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

failed to execute command install yarn mapreduce framework jars on service yarn

avatar
Explorer

i am installing cloudera cdh  6.3.3 with isilon but when adding yarn i am facing this error 

 

any help i will be grateful

log1.PNGlog2.PNG

1 ACCEPTED SOLUTION

avatar
Master Guru

@farouk This seems a known issue and I used to fixed it by adding the required permission : hadoop dfs -chmod -R +x /user/yarn

Can you please try this and see how it goes. 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

View solution in original post

5 REPLIES 5

avatar
Master Guru

@farouk This seems a known issue and I used to fixed it by adding the required permission : hadoop dfs -chmod -R +x /user/yarn

Can you please try this and see how it goes. 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

avatar
Explorer

many thanks

avatar
Contributor

I am having this issue with a brand new cluster install on version 7.13.1 and here is the error I get when I run that command. Who should I be running it as?

chmod: changing permissions of '/user/yarn/mapreduce/mr-framework/3.1.1.7.3.1.0-197-mr-framework.tar.gz': Permission denied. user=root is not the owner of inode=/user/yarn/mapreduce/mr-framework/3.1.1.7.3.1.0-197-mr-framework.tar.gz

avatar
Community Manager

@jkoral As this is an older post, you would have a better chance of receiving a resolution by starting a new thread. This will also be an opportunity to provide details specific to your environment that could aid others in assisting you with a more accurate answer to your question. You can link this thread as a reference in your new post. Thanks.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Contributor

Sorry about that. I'll keep that in mind for the future. I was able to resolve the issue though. Thank you.