Support Questions
Find answers, ask questions, and share your expertise

hi, somebody know why pass this error:

Explorer
ambari-server.service: main process exited, code=killed, status=9/KILL
1 ACCEPTED SOLUTION

Accepted Solutions

Hi @yadir Aguilar ,

i think you should have started the ambari-server using the command

ambari-server start

In that case please use the command

ambari-server status

This is just how systemd works. For systemd to track a process it needs to be started with systemd.
If it is started outside systemd, it won't manage the process and the status will be "not started"

E.g:

# valid flow
ambari-server start
ambari-server status
# valid flow
systemctl start ambari-server
systemctl status ambari-server
# invalid flow
ambari-server start
systemctl status ambari-server

Please accept answer if this helps you :)

View solution in original post

3 REPLIES 3

@yadir Aguilar where and when do you see this error?

Explorer

86642-ambari-service.png

when a the heartbeat don't have response, i run this code: systemctl status ambari-server, so in here i get this error, i execute some commands and the service is runnig again, but this problem pass repeatedly

Hi @yadir Aguilar ,

i think you should have started the ambari-server using the command

ambari-server start

In that case please use the command

ambari-server status

This is just how systemd works. For systemd to track a process it needs to be started with systemd.
If it is started outside systemd, it won't manage the process and the status will be "not started"

E.g:

# valid flow
ambari-server start
ambari-server status
# valid flow
systemctl start ambari-server
systemctl status ambari-server
# invalid flow
ambari-server start
systemctl status ambari-server

Please accept answer if this helps you :)

View solution in original post