Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
07-26-2023
08:38 AM
- last edited on
04-20-2026
11:50 PM
by
GrazittiAPI
Redhat 7 OS.
I try to do a in-place upgrade Cloudera Manager from 7.4.4 to 7.7.1 following the docs:
I do anything, and after the upgrade, I found the cloudera-scm-agent is not stable.
the cloudera-scm-agent log is:
[26/Jul/2023 15:11:31 +0000] 1956 MainThread filesystem_map ERROR NFS server binding info failed with error :- rpcinfo: RPC: Port mapper failure - Timed out
program 100003 is not available
[26/Jul/2023 15:12:31 +0000] 1956 MainThread filesystem_map ERROR NFS server binding info failed with error :- rpcinfo: RPC: Port mapper failure - Timed out
program 100003 is not available
[26/Jul/2023 15:13:31 +0000] 1956 MainThread filesystem_map ERROR NFS server binding info failed with error :- rpcinfo: RPC: Port mapper failure - Timed out
program 100003 is not available
[26/Jul/2023 15:14:31 +0000] 1956 MainThread filesystem_map ERROR NFS server binding info failed with error :- rpcinfo: RPC: Port mapper failure - Timed out
program 100003 is not available
[26/Jul/2023 15:15:31 +0000] 1956 MainThread filesystem_map ERROR NFS server binding info failed with error :- rpcinfo: RPC: Port mapper failure - Timed out
program 100003 is not available
[26/Jul/2023 15:16:31 +0000] 1956 MainThread filesystem_map ERROR NFS server binding info failed with error :- rpcinfo: RPC: Port mapper failure - Timed out
program 100003 is not available
[26/Jul/2023 15:16:32 +0000] 1956 MainThread agent ERROR Heartbeating to mysiteaddress.com:7182 failed.
Any suggestions? Thank you!!
Created 07-27-2023 08:07 AM
After I change to monitored_nodev_filesystem_types=tmpfs in /etc/cloudera-scm-agent/config.ini,
it solve my problem.
Created 07-28-2023 06:28 AM
Glad you resolved the issue. Just to add more context, The error indicates agent was unable to monitor the filesystem, likely the nfs is stuck. This results in agent to be stuck in monitoring the filesystem and unable to heartbeat to CM server. Hence Removing the NFS from monitored filesystem helped to resolve the issue.
Created 07-26-2023 11:09 AM
@h2rr821 Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our CDP experts @venkatsambath and @zzeng who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 07-27-2023 08:07 AM
After I change to monitored_nodev_filesystem_types=tmpfs in /etc/cloudera-scm-agent/config.ini,
it solve my problem.
Created 07-28-2023 06:28 AM
Glad you resolved the issue. Just to add more context, The error indicates agent was unable to monitor the filesystem, likely the nfs is stuck. This results in agent to be stuck in monitoring the filesystem and unable to heartbeat to CM server. Hence Removing the NFS from monitored filesystem helped to resolve the issue.