Support Questions
Find answers, ask questions, and share your expertise

problem receiving Data on HandleHTTPRequest not working properly

Explorer

I have a problem with the HandleHTTPRequest Processor, I'm using it to receive Data from Sensors via a path and a port, the problem is that even If sensors send Data and when using wireshark I see Data coming from sensors to my Integration server in the port assigned , but the processor doesn't show anything until I restart NIFI , Data reach the processor for some minutes or sometime for 2 days and after it stop again , don't know what is the problem , because restarting Nifi every time is not a good solution for me , someone can help me on that ?

2 ACCEPTED SOLUTIONS

Explorer

Hi,

I tried the solution of increasing the Memory , but nothing has changed , the processor still not working 

NIFI.png

View solution in original post

Explorer

I solved the issue with increasing the Request expiration which was set to 1 min .

image.png

View solution in original post

8 REPLIES 8

 

It sounds like your NiFi needs some tweaking, to get things stable.  You should not have to restart NiFi.   If it is stopping/crashing/clogging up after some time online running as expected, this is usually due to instability of NiFi itself, not the processor.

 

 

Can you provide some details about the spec/sizing for the nifi?     Also what is the size of data arriving?

 

Explorer

this is what comes today after restarting Nifi , and stop after :

NIFI.png

 

what do you mean by NIFI size ?

Sizing and spec of the nifi node:

 

Node Ram and Cores

Min/max memory for nifi

 

 

Is the node dedicated to NiFi?  If the Node has other duties too, these may prevent NiFi from having enough resources causing it to crash or get locked up during long term testing (days/weeks).  Restarting NiFi resets this condition, and then it works again.

 

 

First step is to increase the min/max memory,  but sharing the Nifi Node Environment details will help us provide more specific details.

Explorer

The RAM of Nifi Node is 32 G and it has a disk space dedicated just to NIFI and its logs with 250 G , I delete logs every time to not face the problem of low disk , I have just NIFI running in this Node and some small applications like postman and Robot3 not very big to prevent him doing his Job

Ok so bump up the min/max ram in the nifi.properties or in the config (if using ambari or other).   Start with 2gb / 4gb, and go up in steps until you get stability you are looking for.  You should not have to go as high as 16gb / 32gb to be stable.   The default is very low.

 

 

 

Explorer

Okey I will try this tomorrow and give you feedback , thank you so much 

Explorer

Hi,

I tried the solution of increasing the Memory , but nothing has changed , the processor still not working 

NIFI.png

Explorer

I solved the issue with increasing the Request expiration which was set to 1 min .

image.png

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.