Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-14-2013 07:40 PM - edited 09-16-2022 01:48 AM
I am using the cloudera VM and geting below error when run the below command from terminal.
[cloudera@localhost ~]$ hdfs dfsadmin -safemode leave
safemode: Access denied for user cloudera. Superuser privilege is required
Quick help will appreciate.
Created 10-16-2013 12:19 PM
That command must be run as the HDFS superuser (usually "hdfs"). So, try it this way:
sudo -u hdfs hdfs dfsadmin -safemode leave
HTH
Created 10-16-2013 12:19 PM
That command must be run as the HDFS superuser (usually "hdfs"). So, try it this way:
sudo -u hdfs hdfs dfsadmin -safemode leave
HTH
Created 05-03-2014 09:28 AM
this worked for me.
thanks,
raj
Created 11-13-2014 11:19 AM
Thanks Clint !!
Created 02-03-2018 04:43 AM
Thanks. This works for me as well. 🙂
Created 06-26-2018 03:56 AM
thanks sir
Created 10-13-2016 11:52 PM
I am having this issue.
Tried with the command you have given however there is one more error which says -
Java HotSpot(TM) 64-Bit Server VM warning: Insufficient space for shared memory file:
<some value>
Try using the -Djava.io.tmpdir= option to select an alternate temp location.
i am not sure about setting this Djava.io.tmpdir, can you please help ?
Created 03-13-2019 08:08 PM
sudo -u hdfs hdfs dfsadmin -safemode leave
Created 12-21-2022 07:01 AM
yes.i have this issue how to solve it