Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

upgrade HDP 2.4

Solved Go to solution

upgrade HDP 2.4

Super Collaborator

i cant Register Target Version 2.4 into HDP 2.3.4, my ambari version is:

ADMIN_VIEW{2.2.0.0

3115-sin-titulo.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: upgrade HDP 2.4

New Contributor

You need to upgrade Ambari to 2.2.1.x -- this is because there is a newer version of Spark in the HDP 2.4 stack definition.

The primary reason to upgrade to HDP 2.4.x is to obtain the latest version of Spark (1.6.x). If you aren't going to use the latest Spark, I would recommend sticking with the 2.3.x line.

4 REPLIES 4
Highlighted

Re: upgrade HDP 2.4

New Contributor

Understanding that the 2.4 doesn't appear in the dropdown, are you still able to use an arbitrary number and register the correct repo(s) from here: http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.1.1/bk_Installing_HDP_AMB/content/_hdp_24_reposi... ?

Re: upgrade HDP 2.4

New Contributor

You need to upgrade Ambari to 2.2.1.x -- this is because there is a newer version of Spark in the HDP 2.4 stack definition.

The primary reason to upgrade to HDP 2.4.x is to obtain the latest version of Spark (1.6.x). If you aren't going to use the latest Spark, I would recommend sticking with the 2.3.x line.

Re: upgrade HDP 2.4

Super Collaborator

Ok thanks:

actually we are going to use sparkR and i would like to use the last version of spark so, first i need to update de ambari 2.2.1 right??? and then update de hdp???

thanks

Re: upgrade HDP 2.4

Super Collaborator

Hi:

After upgrade the ambari 2.2.1, i can upgrade the hdp 2.4.

Many thanks