Member since
08-08-2024
129
Posts
33
Kudos Received
20
Solutions
My Accepted Solutions
| Title | Views | Posted |
|---|---|---|
| 106 | 09-16-2026 01:45 PM | |
| 214 | 09-03-2026 10:43 AM | |
| 270 | 08-12-2026 04:56 PM | |
| 168 | 07-23-2026 08:29 AM | |
| 277 | 07-22-2026 02:41 PM |
09-21-2026
04:52 AM
I removed the Date Format from the ExcelReader controller and kept the Data Format in the JsonRecordSetWriter and all dates cam out as expected. It appears by leaving the Date Format empty in the ExcelReader but putting MM/dd/yyyy in the JsonRecordSetWriter will work.
... View more
09-19-2026
11:07 AM
Hello @jame1997, Thanks for being part of our community. Is that all the message you have on the logs? Have you checked directly on the nifi-app.log? Usually those messages include more details or traces that show some reason of the failure. If needed, maybe you can add DEBUG level to that processor so we can get more details when it fails. On the logback.xml and under </configuration> add this line: <logger name="org.apache.nifi.processors.standard.GetSFTP" level="DEBUG"/> Then monitor for the next failure, collect the logs and rollback the change.
... View more
09-18-2026
10:59 AM
Hello @AlokKumar, Can you share the CDP and CFM versions? This sounds familiar to a known issue but I will need to check more based on that. Also, can you provide a screenshot of what you see?
... View more
09-16-2026
01:45 PM
Hello @AlokKumar, The basic flow of this would be something like this: 1. Connect your incoming email using ConsumeIMAP, ConsumePOP3, or ListenSMTP, which ever works better for you. 2. Route that to the ExtractEmailAttachments. This processor unpacks the MIME structures into individual FlowFiles, for example text/plain, text/html, application/pdf 3. Using RouteOnAttribute separate the body parts: - body_text: ${mime.type:equals('text/plain')} - body_html: ${mime.type:equals('text/html')} 4. With ExtractText get the email body and capture the information you need. About the javax.mail, you're correct, that is not supported, you should use jakarta.mail types. https://issues.apache.org/jira/browse/NIFI-12820
... View more
09-15-2026
09:38 AM
Hello @vowxx007, The driver port is ephimeral and only exist during the app executions, so for your intention it will not work. There are some options, for example the Spark History Server REST API. For example, http://<server-url>:18080/api/v1/applications returns a JSON with data for both active and completed apps. Then you can play with the options this API offers. Note: check and confirm the SHS Port on the Spark service configuration. Another tool that may work is the YARN Resource Manager REST API there you can use options such as "Cluster Applications API". This one will be something like this: http://rm-http-address:port/ws/v1/cluster/apps That option will give information about the user, start and finish time, status, and more. Hopefully this help you on your monitoring tasks.
... View more
09-03-2026
10:43 AM
1 Kudo
Hello @Softwarebyt, Based on the error posted for @ipson, looks like this matches two NiFi Jiras: https://issues.apache.org/jira/browse/NIFI-13720 https://issues.apache.org/jira/browse/NIFI-13722 Those fixes get included on CFM 2.1.7.1000: https://docs.cloudera.com/cfm/2.1.7/release-notes/topics/cfm-fixed-issues.html And CDF for DataHub 7.3.1.0: https://docs.cloudera.com/cdf-datahub/7.3.1/release-notes/topics/cdf-datahub-fixed-issues-flow-management.html
... View more
08-26-2026
10:20 AM
Hello @ksw, Sorry, just checking more looks like it was to solve an UI bug. Not an specific CVE. For CVE-2025-66035 / GHSA-58c5-g7wp-6w37 I suggest to open a ticket so we can report this with the security team. Can you do that please? If you have a CVE scanner and can run a report would be even better.
... View more
08-25-2026
02:55 PM
1 Kudo
Hello @intersoldi, Thanks for reaching our community. Glad to have you here. The error looks clear on this message: 2024-07-11T07:30:57,262 WARN com.snowflake.kafka.connector.internal.SnowflakeInternalStage: [kafka_snowflake_poc_2|task-0] [SF_KAFKA_CONNECTOR] uploadWithoutConnection encountered an exception:JDBC driver encountered IO error. Message: Encountered exception during upload: null. for filePath:kafka_snowflake_poc_2/existing_table1/0/1_1_1720683056775.json.gz in Storage:AZURE
2024-07-11T07:30:57,265 ERROR com.snowflake.kafka.connector.internal.InternalUtils: [kafka_snowflake_poc_2|task-0] [SF_KAFKA_CONNECTOR] Retry count:0 caught an exception for operation:UPLOAD_FILE_TO_INTERNAL_STAGE_NO_CONNECTION with message:[SF_KAFKA_CONNECTOR] Exception: Failed to execute cached put
Error Code: 5018
Detail: Error in cached put command
Message: JDBC driver encountered IO error. Message: Encountered exception during upload: null. Kafka on CDP have access to the Snowflake domain, but the put on Azure storage is failing. Most likely there is a proxy or firewall that is not helping on this connection. You can test with this command: curl -v https://azure_name.blob.core.windows.net If you have a proxy, try to add it to the KAFKA_OPTS with these options -Dhttps.proxyHost=<proxy_host> -Dhttps.proxyPort=<proxy_port> Also, if you change the connector to Snowpipe Streaming method, that upload can be avoided and possible this issue gets solved. To do that you can update the JSON for the connector with this setting: "snowflake.ingestion.method": "SNOWPIPE_STREAMING" Check those points and see if it helps.
... View more
08-24-2026
04:12 PM
@DevOpsWorld Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. Thanks.
... View more
08-17-2026
12:04 AM
@kiki_adm, Did this response help resolve your query? If so, please consider marking the relevant reply as the accepted solution. This helps other community members find answers more easily in the future.
... View more