Support Questions
Find answers, ask questions, and share your expertise

Connection refused for HDF sandbox

I have been able to connect to HDP sanbox by ssh -p 2222. But with the new HDF sandbox, I was stuck again with the "connection refused" error. After I brought up the sandbox, I tried the URL "http://10.0.2.15:18888/" but just got timeout error. Any idea ? @mqureshi

15 REPLIES 15

Yes, I'm able to log on http://127.0.0.1:9080 and http://127.0.0.1:18888. Can't open http://sandbox-hdf.hortonworks.com:19090/nifi

Have issue with the tutorial script . It says virtualBox command not found. @Sonu Sahi

15691-vboxmanager.jpg


vboxmanager.pngvboxmanager.jpg

I'm able to open Nifi UI by http://localhost:19090/nifi/ . Maybe I can ignore the script error ?

Same issue with script init_nifi_in_src_data.sh. Command not found. It's a pain. You don't have this issue ? @Sonu Sahi

Guru

No, I don't have this issue. I'm able to hit the nifi UI at http://127.0.0.1:19090/nifi/ without a problem

New Contributor

I have the same error (using either IP address or /etc/hosts entry):

ssh root@sandbox-hdf.hortonworks.com -p 12222

ssh: connect to host sandbox-hdf.hortonworks.com port 12222: Connection refused

ssh root@172.17.0.2 -p 12222 -->

ssh: connect to host 172.17.0.2 port 12222: Connection refused

I am using a fresh Dockerized HDF sandbox installed (today) on Ubuntu 16.04 - with the Trucking IoT tutorial set up from here:

https://github.com/orendain/trucking-iot/tree/hadoop-summit-2017#setup-on-existing-hdf-hdp

The weird thing is that the 'shell-in-a-box' works fine (with either IP address or /etc/hosts entry):

http://sandbox-hdf.hortonworks.com:4200

http://172.17.0.2:4200

Anyone have any ideas on what might be amiss? Is this biting anyone else?

Thanks

Mentor

@Steve Hofstra

Have a look at some note in learning ropes for sandbox

That should help