Support Questions

Find answers, ask questions, and share your expertise

HDFS tests (canary, connection) fail after enabling security

Guru

Hi,

after enabling Kerberos security and restarting the cluster, the status of service HDFS shows "Bad", despite the service instances are all "Good".

Seems like just the service checks are failing, error messages from CM:

1.) No connection to determine the active NameNode could be made for the last 3 minute(s)...

2.) Canary test failed to create parent directory for /tmp/.cloudera_health_monitoring_canary_files.

 

and even the Namenode UI cannot be opened successfully => after clicking "Namenode WebUI" (which results in http://hadoop-pg:50070) in service view I receive

"

HTTP ERROR 401

Problem accessing /index.html. Reason:

"

 

How to solve the described issues

a) eliminate failures of hdfs service checks, and

b) being unable to open Namenode-UI 

??

 

thanks in advance, Gerd

 

 

1 ACCEPTED SOLUTION

Expert Contributor

Hey Gerd,

 

The reason you can't get to the NameNode UI is because you have to have a kerberos ticket now to bring it up.  As for the failed canary, did you restart the MGMT services?  Once you enable kerberos, you have to restart the MGMT services so they can get a proper keytab.  That way they can run the canary tests.

 

Can you try restarting the MGMT services and let me know if that helps?

 

Thanks!

Chris

View solution in original post

2 REPLIES 2

Expert Contributor

Hey Gerd,

 

The reason you can't get to the NameNode UI is because you have to have a kerberos ticket now to bring it up.  As for the failed canary, did you restart the MGMT services?  Once you enable kerberos, you have to restart the MGMT services so they can get a proper keytab.  That way they can run the canary tests.

 

Can you try restarting the MGMT services and let me know if that helps?

 

Thanks!

Chris

Guru
Hi Chris,

thanks, restarting the MGMT services solved the test issues.

bye...Gerd...