Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP 2.5 Sandbox not starting

Solved Go to solution

HDP 2.5 Sandbox not starting

Super Collaborator

Hi,

Today I downloaded the Sandbox from http://hortonworks.com/downloads/#sandbox When I start it though it seems like some but not all components are launched. First the Virtualbox screen is stuck in this mode:

7851-screen-shot-2016-09-21-at-94723-pm.png

When you hit a button I get more info:

7852-screen-shot-2016-09-21-at-94624-pm.png

The time counter just runs forever. By this time the Ambari login screen is up and the YARN app WebUI on 8088 as well, but that is it. It is stuck on start up. What is going on?

UPDATE

7892-screen-shot-2016-09-22-at-71256-am.png

After 36 minutes it it still doing something

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HDP 2.5 Sandbox not starting

Super Collaborator

Well, I turned to the Docker version instead. That one is working!

View solution in original post

33 REPLIES 33
Highlighted

Re: HDP 2.5 Sandbox not starting

Rising Star

@ Jasper How much RAM is in the host machine? The newer sandbox has a lot of components in it and typically needs about 8GB of RAM allocated to it in order to run right. One other thing I've noticed is that the 2.5 sandbox takes longer to start than the earlier ones, but after 6+ minutes you should see some progress.

Highlighted

Re: HDP 2.5 Sandbox not starting

Super Collaborator

I have 8GB allocated. Longest time I ran the start up was well over 12 min.

Highlighted

Re: HDP 2.5 Sandbox not starting

New Contributor

@Jasper Even i have the same problem as yours ,my host machine is 16gb , i thought it was related to network settings and troubleshooting for past 2 days but couldn't figure out . If anyone has fixed the pbm please help me out.

Highlighted

Re: HDP 2.5 Sandbox not starting

Can you provide details to your Network settings of VM ? I did face issue getting my VM up due to Network issue. I got it working now.

Highlighted

Re: HDP 2.5 Sandbox not starting

New Contributor

Having the same problem but my host machine has 8gb. I can only allocate about 5gb max.

Highlighted

Re: HDP 2.5 Sandbox not starting

Neil, with 8GB of RAM in the localhost it won't work, it hangs, I tried it and it dint work until I upgraded my RAM capacity to 12 GB.

Highlighted

Re: HDP 2.5 Sandbox not starting

Super Collaborator

Well, I turned to the Docker version instead. That one is working!

View solution in original post

Highlighted

Re: HDP 2.5 Sandbox not starting

Hi, I did a lot of work on HDP 2.4 sandbox on VMWare Player and it worked like charm. I decided to download the HDP 2.5 (to check out the latest offerings) and that too the Virtualbox image and thats when all my troubles began . All hell breaks loose in acquiring an IP address for guest machine. Attached are screenshots for Network Options

8449-default-settings-hdp2-5.jpg

and the final outcome when VM is up after around 10-15 minutes on my machine (i7 Dual Core, 16 Gb RAM) is that

127.0.0.1:8888 IP generated.

And putty fails to connect to this IP .

My questions -

1) Why is it unable to generate a proper IP like it did for HDP 2.4 on VMware (am i doing something wrong)

2) How to get putty to connect to this IP (if at all possible)

What's the deal with docker version ? Can we use it like VM ?

Highlighted

Re: HDP 2.5 Sandbox not starting

Rising Star

The move to docker, meant we had to upgrade the operating system to Centos 7 which is a requirement for Docker. Doing so added this change of not being able to see the step by step progress of the bootup. On virtualbox, if you click inside the console of the VM and type an arrow key, you should see the progress. Typically the initial boot up sequence takes about 3.5 minutes if you have a Core I7 2.3GHZ with 16 GB of physical memory. We are continuing to look into improving the experience.

Don't have an account?
Coming from Hortonworks? Activate your account here