Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
01-21-2021
10:38 PM
- last edited on
04-21-2026
02:07 AM
by
GrazittiAPI
Hello,
We were getting ‘DatabaseError: ORA-01017: invalid username/password; logon denied’ post our db upgrade, to fix that we have reset the hue password, which worked and that issue got fixed.
Unfortunately one of our guys deleted a couple of logs from /var/log/hue. We have recreated runcpserver.log with the necessary permission, and restart Hue server, yet we fail to see the file being populated (file is still empty).
Request assistance / guidance in fixing this issue.
Thanks
Wert
Created 01-25-2021 12:10 AM
@wert_1311 If this is CDH6 or later you might be hitting a known issue with this. Here is the solution.
To resolve this issue, do the following on every Hue server:
#RHEL/Centos
/usr/sbin/alternatives --install /etc/hue/conf hue-conf /opt/cloudera/parcels/CDH/etc/hue/conf.empty 10
This issue occurs if the upgrade does not create or re-create the alternatives for hue-conf to point to /opt/cloudera/parcels/CDH/etc/hue/conf.empty/.
Created 03-02-2022 08:40 PM
@wert_1311 No downtime needed. Only agent CM agent restart on Hue servers may required if you see the alternative not taking effect.
Created 01-25-2021 12:10 AM
@wert_1311 If this is CDH6 or later you might be hitting a known issue with this. Here is the solution.
To resolve this issue, do the following on every Hue server:
#RHEL/Centos
/usr/sbin/alternatives --install /etc/hue/conf hue-conf /opt/cloudera/parcels/CDH/etc/hue/conf.empty 10
This issue occurs if the upgrade does not create or re-create the alternatives for hue-conf to point to /opt/cloudera/parcels/CDH/etc/hue/conf.empty/.
Created 03-02-2022 08:33 PM
Can we run this command while the cluster is in use or do we need downtime, kindly advise
Thanks
Created 03-02-2022 08:40 PM
@wert_1311 No downtime needed. Only agent CM agent restart on Hue servers may required if you see the alternative not taking effect.