Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Impala Catalog Server supervisor permissions


I have a problem on a CDH 5.8.0 parcels testsystem starting the Impala Catalog Server. 

The error message is the following: 


Can't open /var/run/cloudera-scm-agent/process/148-impala-CATALOGSERVER/supervisor.conf: Permission denied.

The permissions for this file are: 


-rw------- 1 root   root    2970 Jun 27 23:01 supervisor.conf

All other files and directories in the /var/run/cloudera-scm-agent/process/148-impala-CATLOGSERVER folder having owner impala and group  impala. 

When I change the permissions it will be overwritten on the next start. 

What is wrong here? 

And what needs to be changed. I recently installed a different service and changed the visudo file, but I have not changed the Impala configuration.


Thanks for the advice.



since i see you logs says that you are  downlading the parcels from /opt/cloudera/parcels/CDH-5.11.1-1.cdh5.11.1.p0.4/lib/impala/../..


it says ( in your log file ) go to



it may direct to mini-dump logs (/var/log/impala-minidumps/impalad / )


if you open the file and if you come across the JRE runtime error plus if it complains about the core dump .




Then it is the bug that is related to Linux kernel , impala's JRE error .

the fix is to increase the Stack thread  . do the below steps


the error should look like this


A fatal error has been detected by the Java Runtime Environment:
#  SIGBUS (0x7) at pc=0x00007fa6b9f80c18, pid=3819, tid=0x00007fa6cfdb4900
# JRE version:  (8.0_131-b11) (build )
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# j  java.lang.Object.<clinit>()V+0
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# If you would like to submit a bug report, please visit:

The fix is

In  Cloduera manager UI -> Cluster -> Go to Impala - Configuration tab .




Step 1 :

Impala Daemon properties:

Impala Daemon Environment Advanced Configuration Snippet (Safety Valve)

apply the  JAVA_TOOL_OPTIONS=-Xss2m


Steo 2 :


Apply the same for Impala Catalog -

"Impala Catalog Server Environment Advanced Configuration Snippet (Safety Valve)"

before you restart the catalog daemon.



Reason - The crash was caused by a change to the linux kernel that modified the memory layout around JAVAthread stacks.


JIRA -   -


Please let me know if that works

View solution in original post



could u share the logs .  

what is the status of other impala dameons ? 

what version of jdk are you using ? 






Screenshot from 2017-07-06 18-18-18.pngScreenshot from 2017-07-06 18-24-06.png


yes my impala daemon is working after adding the java_tool_options=-Xss2m but as same to catalog server i add java_tool_options=-Xss2m its not starting 


and my java version is

java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

New Contributor

Thank you for sharing the solution.


@rroyYou Welcome 🙂


Great it helped me too.