Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 11-20-2016 06:33 AM - edited 09-16-2022 03:48 AM
Hi,
I met this issue https://issues.cloudera.org/browse/KITE-762.
Sqoop1 job works if I remove Hive meastore HA and keep only on metastore server.
How could I disable HA only for sqoop1 client?
Thanks.
Created 11-20-2016 06:48 AM
Created 11-20-2016 06:48 AM
Created 11-20-2016 06:56 AM
Created 01-18-2018 12:16 AM
Hi,
i´m trying to use sqoop via hue, but i keep getting this error:
2018-01-18 08:31:52,353 [main] WARN org.kitesdk.data.spi.hive.MetaStoreUtil - Aborting use of local MetaStore. Allow local MetaStore by setting kite.hive.allow-local-metastore=true in HiveConf 2018-01-18 08:31:52,353 [main] ERROR org.apache.sqoop.tool.ImportTool - Import failed: Missing Hive MetaStore connection URI
Its not the same but seems to be quite similar.
The cluster is useing HA for Hive metastore.
I tried to set the Hive metastore uri like this:
import -Dhive.metastore.uris=thrift://17.239.167.168:9083 -Dkite.hive.allow-local-metastore=true --connect jdbc:exa:17.239.167.201..205:8563;schema=sks_dp_steuerung --driver com.exasol.jdbc.EXADriver --username sys --password exasol --table dbo_institutspartitionen --hive-import --as-parquetfile --hive-table DBO_INSTITUTSPARTITIONEN --hive-database SKS_DP_STEUERUNG -m 1
but it makes no difference.
The Exception tells to set
kite.hive.allow-local-metastore=true
I tried this via
-Dkite.hive.allow-local-metastore=true
I have no idea whether this would be the right way to do this.
Is there something i might have missed? Or is this really a completely different error?