Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

A previous upgrade did not complete.



after trying to express upgrade to 2.6.4 and failing because of Solr mpack, I proceeded to a downgrade back to 2.5.0.

The downgrade finished with:

org.apache.ambari.server.AmbariException: The following 3 host component(s) have not been downgraded to their desired versions: SOLR_SERVER (current = UNKNOWN, desired = SOLR_SERVER (current = UNKNOWN, desired = SOLR_SERVER (current = UNKNOWN, desired =

	at org.apache.ambari.server.serveraction.upgrades.FinalizeUpgradeAction.finalizeDowngrade(
	at org.apache.ambari.server.serveraction.upgrades.FinalizeUpgradeAction.execute(
	at org.apache.ambari.server.serveraction.ServerActionExecutor$Worker.execute(
	at org.apache.ambari.server.serveraction.ServerActionExecutor$

Because I have installed solr-service-mpack- and the Ambari predict version of Solr is the same as HDP 2.5.0 stack, but it was from mpack. This was the same reason why the upgrade did not finished.

Anyway, I removed from all slave hosts the Solr from mpack and succefully deleted Solr service from Ambari. When I try to do a new upgrade without cause of problems, I get those:

Reason: There is an existing downgrade from which has not completed. This downgrade must be completed before a new upgrade or downgrade can begin.

I already tried those commands:

[hdfs@host1-master ~]$ hdfs dfsadmin -finalizeUpgrade
Finalize upgrade successful for
Finalize upgrade successful for
[hdfs@host1-master ~]$ hdfs dfsadmin -rollingUpgrade finalize
FINALIZE rolling upgrade ...
There is no rolling upgrade in progress or rolling upgrade has already been finalized.

I also tried to disable "preUpgradeCheck" in Ambari's experimental mode, but it didn't helped as well. I get:

An internal system exception occurred: Unable to perform upgrade as another downgrade (request ID 449) is in progress.

Please, can you help me with stuck on upgrade?



I solved the issue by Ambari DB restore.

View solution in original post



I solved the issue by Ambari DB restore.