Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Please see the Cloudera blog for information on the Cloudera Response to CVE-2021-4428

Cloudera parcel installation is stuck in distribution phase

Explorer

parcels.jpgParcel Distribution-stuck.jpgscm-sever-log.jpg

 

Hi All,

 

I'm stuck at the cdh5.10 parcel distribution phase during parcel installation stage. The DNS and passwordless scp is working fine between 3 hosts (m.home.org,s1.home.org,s2.home.org)in virtualbox.

 

As one can see in above snaps, its showing 100% downladed. But at the distribution it has been stuck for more than 6 hours now. And also I've 30 GB free space in /opt.

 

What could be the reason? What is the solution?

 

Regards,

Mrinal 

5 REPLIES 5

Champion
Take a look at the CM agent logs for the hosts. The distributions phase of the install is the CM agents downloading the parcel from the CM host. Whatever problem there is it should be reported there.

Explorer

Hi Mrinal 

I have the same issue.

Do you have any solution to it?

 

I have ensured i have sufficient RAM ( >200GB) and Disk space(>50GB) in "/opt/cloudera/".

 

I also tried downloading a different parcel (CDH5.9) but still no progress.

 

With Regards 

Dino

Explorer
Please check your java version.
It should be 1.8 or latest one.

Explorer

Apart from Java Versioning, did you make any other changes? 

I tried using java 1.7 and 1.8 but both failed

Explorer
I removed all java using yum uninstall java*...Then downloaded the fresh
java from oracle website. Make sure you are not using OPEN java anywhere.
Then set Java path properly. It should work then..