Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Datanode start fails in ambari vagrant setup

Solved Go to solution

Datanode start fails in ambari vagrant setup

Contributor

My setup is a 3 node VM cluster as mentioned in Quick Start guide.

When i run Start all services it fails at datanode start with error

/usr/hdp/2.4.2.0-258//hadoop-hdfs/bin/hdfs.distro: line 317: /home/vagrant/jdk1.8.0_60_x64/bin/java: Permission denied /usr/hdp/2.4.2.0-258//hadoop-hdfs/bin/hdfs.distro: line 317: exec: /home/vagrant/jdk1.8.0_60_x64/bin/java: cannot execute: Permission denied ulimit -a for user hdfs core file size (blocks, -c) unlimited data seg size (kbytes, -d) unlimited scheduling priority (-e) 0 file size (blocks, -f) unlimited pending signals (-i) 22958 max locked memory (kbytes, -l) 64 max memory size (kbytes, -m) unlimited open files (-n) 128000 pipe size (512 bytes, -p) 8 POSIX message queues (bytes, -q) 819200 real-time priority (-r) 0 stack size (kbytes, -s) 10240 cpu time (seconds, -t) unlimited max user processes (-u) 65536 virtual memory (kbytes, -v) unlimited file locks (-x) unlimited ~

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Datanode start fails in ambari vagrant setup

@Aman Poonia

Error says:

/home/vagrant/jdk1.8.0_60_x64/bin/java: Permission denied

So can you please check if your Java has 755 (or execute permission) for the user ?

try setting

chmod 755 -R /home/vagrant/jdk1.8.0_60_x64/bin
2 REPLIES 2

Re: Datanode start fails in ambari vagrant setup

@Aman Poonia

Error says:

/home/vagrant/jdk1.8.0_60_x64/bin/java: Permission denied

So can you please check if your Java has 755 (or execute permission) for the user ?

try setting

chmod 755 -R /home/vagrant/jdk1.8.0_60_x64/bin

Re: Datanode start fails in ambari vagrant setup

Contributor

This didn't work for me so i finally destroyed the setup and recreated a fresh setup. And it worked. Thanks @jk for the pointers.