Support Questions
Find answers, ask questions, and share your expertise

ambari server problem 3

Solved Go to solution
Highlighted

ambari server problem 3

Explorer

 Caused by: java.sql.SQLException: Connections using insecure transport are prohibited while --require_secure_transport=ON. at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:965) at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3973)

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: ambari server problem 3

Super Mentor

@Manoj690 

As we see the mentioned message "require_secure_transport=ON" in your exception

which indicates that you might have configured your MySQL to allow secure connections.  You can find that setting inside the "/etc/my.cnf"

 

Option-1). Hence ether you will need to disable that setting from mysql config and restart MySQL. If it is ON means it is enabled.

 

# grep 'require_secure_transport' /etc/my.cnf
require_secure_transport = OFF

# systemctl restart mysql.service

 


Option-2). OR you will need to Get the MySQL service certificate and then make sure that you import the MySQL certificate inside the AmbariServer truststore OR insie the JDK cacert in which your AmbariServer is running.

Example: Importing MySQL CA Certificate in AmbariServer's JDK Truststore :

 

# /usr/jdk64/jdk1.8.0_112/bin/keytool -import -file /tmp/mysql_cert.pem -alias mysql_ambari -keystore /usr/jdk64/jdk1.8.0_112/jre/lib/security/cacerts

 


The restart AmbariServer.

 

# ambari-server restart

 


.

View solution in original post

4 REPLIES 4
Highlighted

Re: ambari server problem 3

Super Mentor

@Manoj690 

As we see the mentioned message "require_secure_transport=ON" in your exception

which indicates that you might have configured your MySQL to allow secure connections.  You can find that setting inside the "/etc/my.cnf"

 

Option-1). Hence ether you will need to disable that setting from mysql config and restart MySQL. If it is ON means it is enabled.

 

# grep 'require_secure_transport' /etc/my.cnf
require_secure_transport = OFF

# systemctl restart mysql.service

 


Option-2). OR you will need to Get the MySQL service certificate and then make sure that you import the MySQL certificate inside the AmbariServer truststore OR insie the JDK cacert in which your AmbariServer is running.

Example: Importing MySQL CA Certificate in AmbariServer's JDK Truststore :

 

# /usr/jdk64/jdk1.8.0_112/bin/keytool -import -file /tmp/mysql_cert.pem -alias mysql_ambari -keystore /usr/jdk64/jdk1.8.0_112/jre/lib/security/cacerts

 


The restart AmbariServer.

 

# ambari-server restart

 


.

View solution in original post

Highlighted

Re: ambari server problem 3

Explorer

if i run this command its asking keyword password:  (what was the password)

 

/usr/jdk64/jdk1.8.0_112/bin/keytool -import -file /tmp/mysql_cert.pem -alias mysql_ambari -keystore /usr/jdk64/jdk1.8.0_112/jre/lib/security/cacerts
Enter keystore password:

Highlighted

Re: ambari server problem 3

Super Mentor

Password is "changeit" which is default cacert password.

Highlighted

Re: ambari server problem 3

Explorer

Thanks a lot

 

finally ambari server started