Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

impala error - ERROR: ExecPlanRequest rpc query_id


I get the below error on impala 1.2.3 version. I did the recycle of all the impalad on cluster but still I get the below error when use “select * tablename” but same select statement works from hive.


ERROR: ExecPlanRequest rpc query_id=8641141086f3ab8e:8ff3926e0f221e91 instance_id=8641141086f3ab8e:8ff3926e0f221e95 failed: ECONNRESET


I have not seen this error before but I ran out of disk space on couple of nodes and I think it caused this issue.






This problem has been solved!

Want to get a detailed solution you have to login/registered on the community


Super Collaborator
This looks more like the affected impalad crashed or somehow disappeared
from the cluster. Can you check it's logs to see why it disconnected from
the statestored?

New Contributor

Impalaissue1.jpgWe already shared exception from Impala logs of affected node. But "ThriftServer" log came about 90 minutes later when node connection was lost. There is no other error/exception in impala log.

Please let me know if there is some other log we can check into. This event happened multiple times. In one node the service is down but we still see process running. See attachment.

Even kill -9 pid is not honoring. 


Also when one node is impacted my application running on Weblogic 11g looses all connection and we had to restart application servers for getting connection back. This is becoming annoying.

Please let me know what we can do to get to root cause of problem.


Super Collaborator
Impala should write its logging information to several logfiles, which
contain the words INFO, WARNING, ERROR, FATAL in their name. Have you
checked all of them for the affected time range?





E0914 10:58:10.457620 94112] stderr will be logged to this file.
W0914 10:58:10.467237 94112] LDAP authentication is being used with TLS, but without an --ldap_ca_certificate file, the identity of the LDAP server cannot be verified. Network communication (and hence passwords) could be intercepted by a man-in-the-middle attack
E0914 10:58:13.220167 94268] ThriftServer 'backend' (on port: 22000) exited due to TException: Could not bind: Transport endpoint is not connected
E0914 10:58:13.220221 94112] ThriftServer 'backend' (on port: 22000) did not start correctly
F0914 10:58:13.221709 94112] ThriftServer 'backend' (on port: 22000) did not start correctly
. Impalad exiting.


Can you help me?


there is a possibility that your daemon process is hung
find it and kill it
$> ps -eaf|grep impala
impala 4399 1 0 Aug17 ? 00:00:00 python2.7 /usr/lib64/cmf/agent/build/env/bin/cmf-redactor /usr/lib64/cmf/service/impala/ impalad impalad_flags false
clouder+ 8426 5709 0 16:34 pts/0 00:00:00 grep --color=auto impala
impala 12322 1 0 Aug17 ? 00:00:00 /opt/cloudera/parcels/CDH-5.10.1-1.cdh5.10.1.p0.10/lib/impala/sbin-retail/impalad --flagfile=/run/cloudera-scm-agent/process/3639-impala-IMPALAD/impala-conf/impalad_flags

$>sudo kill -9 12322
$>sudo kill -9 4399

try to restart your daemon


and check the port

$> sudo netstat -lntp|grep 22000