Support Questions
Find answers, ask questions, and share your expertise

Getting Error while starting HUE services

Rising Star

Team ,

 

I have installed HUE using the below steps .

 

https://github.com/steven-dfheinz/HDP2-Hue4-Service.

 

I was able to install HUE successfully ,but it fails to start . below is the error i am getting .

 

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/HUE/4.6.0/package/scripts/hue_server.py", line 76, in <module>
    HueServer().execute()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 375, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/HUE/4.6.0/package/scripts/hue_server.py", line 26, in start
    import params
  File "/var/lib/ambari-agent/cache/common-services/HUE/4.6.0/package/scripts/params.py", line 194, in <module>
    webhdfs_url = format('http://' + dfs_namenode_http_address + '/webhdfs/v1')
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/config_dictionary.py", line 73, in __getattr__
    raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'dfs.namenode.http-address' was not found in configurations dictionary!

 

Any help would be appreciated  .

 

Regards Bharad

1 ACCEPTED SOLUTION

@bhara 

Change the line 193 below and try to start again.

 
File:/var/lib/ambari-agent/cache/common-services/HUE/4.6.0/package/scripts/params.py
 
dfs_namenode_http_address = config['configurations']['hdfs-site']['dfs.namenode.http-address']
to 
 
dfs_namenode_http_address = 'localhost'
That will give dfs_namenode_http_address a value and get past the error.

View solution in original post

1 REPLY 1

@bhara 

Change the line 193 below and try to start again.

 
File:/var/lib/ambari-agent/cache/common-services/HUE/4.6.0/package/scripts/params.py
 
dfs_namenode_http_address = config['configurations']['hdfs-site']['dfs.namenode.http-address']
to 
 
dfs_namenode_http_address = 'localhost'
That will give dfs_namenode_http_address a value and get past the error.
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.